sep
21
2012

Actualizar PHP y Mysql en Debian Squeeze desde repositorios

Para los que nos dedicamos profesional o no-profesionalmente al desarrollo con PHP y MySQL, uno de los problemas con los que nos encontramos habitualmente cuando trabajamos con servidores Debian es que mantiene paquetes con versiones muy inferiores a los que encontramos en las páginas oficiales, y entre ellos se encuentran los paquetes de PHP y MySQL tan importantes para nosotros.

Para todos aquellos que intentan mantenerse al día con PHP y MySQL hay un repositorio específico para Debian Squeeze que puede ayudarnos, se trata del Dotdeb (http://www.dodeb.org). Para agregarlo a nuestros paquetes baste con importarlo de la siguiente forma (como usuario ROOT):

Editar el archivo /etc/apt/sources.list

Añadimos el repositorio de Dotdeb:

#DOTDEB
deb http://packages.dotdeb.org squeeze all
deb-src http://packages.dotdeb.org squeeze all

Si queremos optar por la rama de desarrollo de PHP(5.4):

#DOTDEB
deb http://packages.dotdeb.org squeeze-php54 all
deb-src http://packages.dotdeb.org squeeze-php54 all

Importamos la KEY del repositorio:

wget http://www.dotdeb.org/dotdeb.gpg
cat dotdeb.gpg | sudo apt-key add -

Actualizamos:

aptitude update

Ya podemos instalar PHP y MySQL

aptitude install php5 mysql-5.5

El listado de paquetes de este repositorio lo tienes aqui.

1 Comentario + Añadir Comentario

  • Undeniably consider that that you stated. Your favorite justification seemed to
    be on the web the easiest thing to take note of.
    I say to you, I definitely get annoyed while people consider worries
    that they just do not understand about. You managed to hit
    the nail upon the top and defined out the entire
    thing with no need side-effects , other people can take a
    signal. Will likely be again to get more. Thanks

Deja tu comentario

Publicidad